“Kinovea for Dummies”

Class User Manual to supplement Kinovea help files
by the Students in Bio 131L – Image Analysis
(edited by Dr. Catherine Loudon)

Topics:

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to select a frame</td>
<td>2</td>
</tr>
<tr>
<td>More detail on selecting frames</td>
<td>3-5</td>
</tr>
<tr>
<td>How to set and change the working zone</td>
<td>6-7</td>
</tr>
<tr>
<td>How to select a specific number of frames in a working zone</td>
<td>8-9</td>
</tr>
<tr>
<td>Selection of 10 frames around a target frame using a key frame</td>
<td>10-12</td>
</tr>
<tr>
<td>How to display speed of tracked object</td>
<td>13-14</td>
</tr>
<tr>
<td>Setting the origin and adjusting axes</td>
<td>15-17</td>
</tr>
<tr>
<td>How to set the calibration scale for distance measurement</td>
<td>18-19</td>
</tr>
<tr>
<td>Correction to auto tracking</td>
<td>20-22</td>
</tr>
<tr>
<td>Exporting data to Microsoft Excel</td>
<td>23-25</td>
</tr>
<tr>
<td>Different ways to save your Kinovea projects</td>
<td>26</td>
</tr>
<tr>
<td>Tracking the speed of an object</td>
<td>27-28</td>
</tr>
</tbody>
</table>
How to select a frame

There is no part of the Kinovea manual that instructs students how to select a frame. After importing a specific video, students can start playing the video while paying really close attention to the motion in the video and hit pause at the frame of interest. In the picture to the right, there is a long green line with a vertical black line which shows the time mark (as indicated).

Leaving the video in still motion, the “go to previous/next frame” button which lies next to the play button allows students to manage frames in slow motion. With this method, one can select the exact frame or moment of interest (see the red boxes below).

From that frame, the student can now count how many frames forward she/he is going to need for the data export out to Excel. For example, the students can click the “go to next frame” button 10 times which corresponds to 10 frames. Now we can scale down the total frames by dragging the blue box at the end of the green line to the left to where the black line is. As shown below, the green line has decreased significantly. Now we can drag the blue box at the beginning of the green line to the right. The duration below the green line notes the numbers of frames in total. For instance, a duration of 0:00:00:20 indicates a total of 20 frames, so we will drag the blue box in accordance to our requirement.
More detail on selecting frames – from starting the program to tracking

1. Click the [start] button on the bottom left-hand corner of the screen.

2. a. Move the mouse arrow to [Programs]. The symbol will turn blue and programs available will be displayed.

   b. Move mouse arrow over [Kinovea]. The Kinovea program will be shown.

   c. Move mouse over [Kinovea].

   d. Click [Kinovea] and the Kinovea program will open.

   ![Fig 1: After 2a-c your screen looks like this:](image1)

   ![Fig 2: After you click on Kinovea your screen looks like this:](image2)

3. Videos that can be edited on Kinovea will appear in the Kinovea window (see Fig 2 above). Click on the appropriate video. The video will enlarge to take up the whole Kinovea window.

   ![Kinovea window with video](image3)

4. a. Press the [Play] button to play the video. The place in the video will be shown as a black line on a green track.
b. Move the blue speed marker back and forth to change the speed at which the video is played so that you can select the segment of the video that you want (see step 5 below).

5. Determine which segment, or frame set, you want. The frame set consists of the frames you want.

6. Press to stop the video at the beginning of your frame set. Click on at left side of the green track and drag it to where the black line is.

7. Press to stop the video at the end of your segment/frame set. Click on at right side of the green track and drag it to where the black line is.

8. You have now chosen your segment/frame set.

9. Click on at the top of the Kinovea window.

10. a. Move the mouse arrow to . The symbol will turn yellow and options will be displayed.
    b. Click on
    c. Your screen will look like
11. Right-hand click on your video. You will see:

Click on Track Path. You have now told Kinovea to track the motion of an object. See other references for more information on tracking a path.

12. (Similar to steps 1-2 and steps 9-10). Click on Export to Spreadsheet, and then HTML. See additional references for more information on exporting data.
How to set and change the working zone

1. Open Kinovea
2. In the left top corner of the screen, left-click on the “File” button
3. In the pop-up window, navigate to the desired video. By selecting the file and clicking on “Open” button, Kinovea will import selected video. A small pop-up window will automatically show up with “importing frames” processing bar.

   a. Once the whole video will be imported, the processing bar will disappear and the selected video will appear in the main Kinovea window.
4. At the button of the screen, there is a player controls.

   Indicated above, these are the main buttons to navigate around the video. The button that looks like a small green capsule
5. Among them, there are 4 buttons grouped together as “working zone”. They are indicated on the image below.
6. A working zone defines a set of frames in which any type of “work” (such as adding effects, text, line, etc.) can be done. Working zone can be set equal to or less than the duration of the whole movie.
7. A working zone is set using two key buttons, “set the first frame of the working zone to the current frame” and “set the last frame of the working zone to the current frame”.
8. To set the first or the last frame to any frame in the movie, use navigation bar to get to the desired frame and click on “set the first frame of the working zone to the current frame”.
9. Once the working zone is set, there are 3 basic actions that can be done next
   a. Click on “Lock working zone boundaries” to lock working zone to the selected frames.

   b. You can change or working zone by click on either ends of it and literally dragging the ends to the desired frames by pressing and holding either or .
c. By clicking on this button, working zone resets to the length of the full video

i.

d. Note that after each manipulation with the working zone “importing frames” processing bar will appear while Kinovea is processing the changes.
How to select a specific number of frames in a working zone

1. Default setting displays movie in hour: min: seconds. To change to frames, click on Options tab ➔ Time markers format ➔ select Frame Numbers

2. To obtain the correct desired number of frames, locate the beginning of the working zone by clicking the [ icon on the first frame of the working zone, and ending the working zone by clicking the ]. In order to obtain X number of frames, watch the position located at the bottom left of the Kinovea screen as the video is played back, ending the working zone when the position value is the correct number of frames. *(adjusting the speed to be slower is usually necessary)*
Selection of 10 frames around a target frame using a key frame

1. Find the target frame with navigation cursor (marked with red rectangle below).

2. Once you find the target frame, click on **Add a Key Frame** (marked with red rectangle below) so you can be sure later on which frame is your target frame.

Below is a picture of what it will look like once you selected the target frame as a key frame. From now on, you can go directly to the target frame by clicking on the image (shown with the red arrow).
3. Set the playback speed to the slowest speed possible (Speed Control marked with red rectangle below), so it is easier to work with each frame.

4. Use the Player Control button (marked with red rectangle) to select 5 frames before the target (target frame is the 6th frame)

5. After you find the 5 frames before the target frame, click on Start Working Zone (marked with red rectangle) to set the first frame of the working zone.

6. Go back to the target frame by clicking on the image (see #2 above), and again using the Player Control button (marked with red rectangle), select 4 frames after the target frame.
7. Then click on the **End Working Zone** (on the right as indicated below by the red rectangle) to set the last frame of the working zone.

![End Working Zone](image)

Below is the picture of what the screen should look like after you finish selecting the Working Zone. Scroll back to the beginning and click on **Player Control** (see step #6); every click will bring you to the next frame in the movie. Check the **Position**, which tells you in what frame you are at in the working zone, as you click through the frames in the working zone with the **Player Control**. The movie should start with “Position 1” and end with “Position 10,” as there should be 10 frames total in the working zone.

![Player Control](image)
How to display speed of tracked object

Step 1 – After tracking the path of your object, return to the first frame by clicking the button.
Step 2 – On the first frame, right click the that marks the desired tracked object.

Step 3 – A scroll menu will appear after right clicking, then select “Configuration.”

Step 4 – A selection menu will appear. Click the arrow next to “Measurement” and select “Speed.”
Step 5 – Click “Apply” and the speed will now be shown next to the object in each frame.
Setting the origin and adjusting axes

The coordinates in a movie are vital to calculate where the object is located relative to other objects also in the video. The coordinates can also serve to calculate velocities in the x-axis and y-axis direction. To do this, begin by recording a video:

1) Open the Kinovea program

2) Here we have the action of throwing a paper plane.

3) Record action with a compatible video recorder. Acceptable formats include: AVI, MPG, MOV, WMV, MP4, MKV, VOB, 3GP, MOD, TOD.

4) Upload video into Kinovea by locating file on your computer. (Shown by red arrow)

5) Once the video is imported click on the Image tab. (Shown by red arrow)
6) Scroll down and select **Coordinates system origin**. (Shown by red arrow)

7) Window will pop-up named **Set coordinates system origin**.

8) Place cursor (shaped as crosshairs 🧐) where the origin is to be fixed. Once placed, select the point by a mouse click (Shown by red box).
9) Select **Apply**. Now when data is recorded or exported into an Excel file, coordinates will be relative to the selection made in the previous slide. X-component and Y-component velocities may be calculated using this data.

<table>
<thead>
<tr>
<th>Coordinates (x, y, t, time, seconds)</th>
<th>(velocity)</th>
<th>X-component velocity</th>
<th>Y-component velocity</th>
<th>Total Velocity</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>-10.22</td>
<td>-15.32</td>
<td>0.00000000 (1)</td>
<td>0</td>
</tr>
<tr>
<td>12</td>
<td>-13.22</td>
<td>-15.32</td>
<td>0.00000001 (2)</td>
<td>0</td>
</tr>
<tr>
<td>13</td>
<td>-7.43</td>
<td>-18.31</td>
<td>0.00000003 (3)</td>
<td>0</td>
</tr>
<tr>
<td>14</td>
<td>-4.27</td>
<td>-16.16</td>
<td>0.00000004 (4)</td>
<td>0.33</td>
</tr>
<tr>
<td>15</td>
<td>-0.37</td>
<td>-15.42</td>
<td>0.00000005 (5)</td>
<td>0.16666667</td>
</tr>
<tr>
<td>16</td>
<td>-4.27</td>
<td>-16.16</td>
<td>0.00000006 (6)</td>
<td>0.15</td>
</tr>
<tr>
<td>17</td>
<td>7.99</td>
<td>-15.31</td>
<td>0.00000007 (7)</td>
<td>0.19353333</td>
</tr>
</tbody>
</table>
How to set the calibration scale for distance measurement

1. Open a movie clip by left-click on File from the top -> Open Video File. Select a movie that you want to work on.

2. Have an actual measurement of reference in the clip. In an example shown, a blue paper was the reference (22.86 cm x 30.48 cm).
3. Left-click on “Line” from the bar under the movie frame.

4. Draw a line by left-click on one point of the reference and drag to the other point. You can adjust it more accurately by zooming-in (Ctrl + Scroll Wheel with the cursor on the movie screen).
5. Left-click on the line drawn to select. Then, right-click on the line to open the menu. Left-Click on “Calibrate Measure”.

6. Enter the value of the actual measurement for the reference in a left box (Here, we use 30.48). Make sure you select a right unit from drop-down bar (Here, we use “cm”). Then Left-click on “Apply” button.

7. Finished! Every measurement in the movie is now calibrated!
Correction to auto tracking

For movies that are not perfectly clear or crisp, the Auto-track option on Kinovea tends to lose the object tracked and present an incorrect path. To fix this you must manually fix the auto-tracking and here is how:

**To begin Auto-tracking:**
1) Right click on the object you want to track  
   a. Select “track path”
2) Moving the movie forward using the “play” button (marked by red box below). This will allow Kinovea to auto-track the selected object through the rest of the clip

These figures show an example of the inaccurate auto-tracking using the “play button”:

Figure 1: Here you can see the original track point is set on the wrist and the tip of the plane

Figure 2: Due to the unclear image, you can see that the tracking marker has lost both the wrist and the tip of the plane and slipped to a different part of the figure
Figure 3: At the end of the motion, we can see the auto tracked path is clearly not the tracked path of the object we originally marked.

To fix this incorrect tracking:
1) Right click on the object you want to track
   a. Select “track path”
2) Instead of moving movie forward by pushing play button, instead use “go to next frame” button
   (Indicated by red box below)

   ![Red box indicating “go to next frame” button]

   - This way you will be able to access the placement of the tracking marker for each frame
3) If the tracking marker has moved from your original placement and you will need to readjust
   a. To do this, right click on the tracking marker and select “restart path edition”
4) This will bring up a ![Correction marker](image) marker. Left click on this symbol and you can drag the + to the point which you originally tracked. After placing the + in the correct position on the selected object, the tracked path will be automatically corrected to the placement of the marker which you choose.
5) Continue this process through all of the frames which you wish to track.
6) After you have finished adjusting the auto track for all frames, you can go back to beginning and push the “play” button to view the corrected tracked path.

These figures show an example of the previous incorrect auto-track shown above fixed using the technique just described:
Figure 4: Here we have chosen the same points as we did in the previous example.

Figure 5: Here the auto track has been corrected and placed on the original points which were selected.

Figure 6: Here you can see the corrected auto-track path is a much better representation of the movement of both objects.
Exporting Data to Microsoft Excel

1. Exporting data

Once you have defined your numerical data (i.e. tracking data) you can export the data in Kinovea using the menu under **File > Export to Spreadsheet > Trajectories to simple text.**

Then save your file. This will save the file in the format, “.txt”

2. Import data to Excel

Open the excel file that you would like to import the data to. Using the menus under **Data** tab, click on **“From Text”** located in the “General External Data” box.

Then a window will prompt asking you to locate the required file. Locate your saved file from Kinovea and click **“Import”**
The “Text Import Wizard” window will prompt and guide you through on the specification of how you would like to import the file.

Click “Next”. This will lead you to step 2 of 3 in the wizard. In step 2, you can manually adjust the column breaks if needed.

Press “Next” and you will be led to the last step of the wizard.
In step 3, you can adjust the format the data if desired. Otherwise, click “Finish.” The file is now successfully imported into Microsoft Excel.
Different ways to save your Kinovea projects

1. Use menu File → Save or use the toolbar's “Save” button.
2. You will have 4 options:
   a. Save video only
   b. Combine video and key images data in the file
   c. Permanently paint key images data on the video
   d. Save only the key images data
3. Saving a file means preserving your selected working zone, current slow motion value and other preferences.
4. Supported output formats include MKV (Matroska), MP4, and AVI.
5. Supported codec for output is MPEG4-ASP (which is DivX/Xvid compatible).
6. If key images data were added to the video, by default it will save as option “b” above, Combine video and key images data in the file.
   a. This method separates the original images from the key images data within the same file.
   b. Opening this type of saved file in Kinovea allows you to modify your drawings, stopwatches, paths and comments.
   c. Opening this type of saved file in another program only allows you to view the original images.
7. If you desire to export your video so that your drawings, stopwatches and paths are visible if opening the video using another program, use option “c” to save the file, Permanently paint key images data on the video.
   a. However, your written comments on the key images will be lost.
8. To save only the original, raw images then select option “d,” Save only the key images data.
Tracking the speed of an object

Step 1: Selecting an object to track
Right click on the point/object in the digital video that you want to track and click “Track Path”
A blue box with a crosshair will appear over the object. We can use this later to correct for the desired object path for analysis.

Step 2: Tracking and correcting the object movement path
Allow the Kinovea program to automatically track the path of the object by viewing the video frame by frame, using the keyboard arrow buttons (right or left arrows) to move through the video. You may correct errors in the automatic object tracking by dragging the blue crosshair box to the correct path and position during each frame of movement for the object.

(Drag from the small blue crosshair to the point desired.)

Step 3: Calibration
In order to measure the speed of the object, we must calibrate the scale of the video with a reference sized object. In this example, we used an A4 sheet of letter paper to calibrate (30.48 cm in width). Make sure the plane of the reference material is parallel to the camera lens for maximum accuracy in your measurements.

First we create a solid line on top of a reference length in the video. Press the “line” button on the bottom taskbar and it allows you to drag a neon green line from point to point (Hold, and release button at
the end) in the video.

Next, right click the created line and click on “Calibrate measure...” then fill in the real size of the indicated segment in the desired units.

**Step 4: Configure measurement for speed**
Right click the tracked path, click “configuration”, and set the measurement for “Speed”.

**Step 5: Measuring speed and exporting data**
First, replay the video with the entire tracked path so that Kinovea will calculate the speed of the tracked object in each digitized frame. The speed of the tracked point is shown in the blue box in each successive frame, following the small black and white roundel.

Export the data by clicking “File>export to Spreadsheet” and then choosing the desired export format. The current Kinovea version 0.8.7 exhibits incompatibility with some user system configurations when exporting to Excel (MS-XML) format due to the recent changes by Microsoft to its original “.xls” format, so we recommend the majority of users to export desired data to XHTML format. The XHTML formats are opened with any current web browsers (i.e. Firefox, Google Chrome) and then relevant data can be copied into Excel, with spreadsheet formatting kept intact due to the transposable nature of XML structured data.